/dotfiles.nix

Dotfiles super-powered by Nix and home-manager

Primary LanguageVim Script

Dotfiles.nix

Dotfiles, powered by Nix and home-manager.

How to use

  1. Install Nix:
    $ sh <(curl -L https://nixos.org/nix/install)
  2. Enable Nix Flakes:
    $ mkdir -p ~/.config/nix
    
    $ cat <<EOF >> ~/.config/nix/nix.conf
    experimental-features = nix-command flakes
    EOF
    
    $ sudo launchctl kickstart -k system/org.nixos.nix-daemon
  3. Go inside your ~/.config directory and clone this repo:
    $ mkdir ~/.config && cd ~/.config && \
      git clone https://github.com/Arkham/dotfiles.nix.git nixpkgs && cd nixpkgs
  4. Run the flake and activate your env:
    $ nix run . && home-manager switch -b backup
  5. Then you can update it with:
    $ nix flake update && home-manager switch