/dots.nix

All-in-one dots repo for nixos

Primary LanguageNixMIT LicenseMIT

Nixos and home config

Installation

nix-channel --add https://channels.nixos.org/nixos-unstable
nix-channel --update

ln -s ${pwd} /etc/nixos
sudo nixos-rebuild switch --flake '/etc/nixos#<device>'

Add new device

mkdir ./hosts/ nixos-generate-config --show-hardware-config > ./hosts//hardware.nix