/autorosvpn

RouterOS and China IP address list (chnroutes.txt)

Primary LanguageRouterOS ScriptMIT LicenseMIT

autorosvpn

China Routes and Cloud Service Provider Routes.

Usage

address-list.rsc

Router OS only import script:

:log info "start download address-list.rsc ..."
/tool fetch http-method=get url=https://raw.githubusercontent.com/zealic/autorosvpn/master/address-list.rsc
:log info "address-list.rsc downloaded."
/file {
  :local addrFile
  :local fileSize
  :set addrFile [find where name="address-list.rsc"]
  :set fileSize [get $addrFile size]
  :if ($fileSize > 300000) do={
    /import file=address-list.rsc
    :log info "NoVPN address list updated!"
  }
}

chnroutes

**路由表

  • chnroutes
    **路由表
  • chnroutes-cernet
    **教育网路由表
  • chnroutes-chinanet
    **电信路由表
  • chnroutes-cmcc
    **移动路由表
  • chnroutes-cnc
    **联通路由表
  • chnroutes-cnnic
    **CNNIC
  • chnroutes-crtc
    **铁通路由表

Cloud Service Providers Routes

Web Sites

TODO

Parse routes from: